Elite Games - Свобода среди звезд!
.
  » Электронная бухгалтерия - 1с и тд. | страница 1
Конференция предназначена для общения пилотов. Для удобства она разделена на каналы, каждый из которых посвящен определенной игре. Пожалуйста, открывайте темы только в соответствующих каналах и после того, как убедитесь, что данный вопрос не обсуждался ранее.

Поиск | Правила конференции | Фотоальбом | Регистрация | Список пилотов | Профиль | Войти и проверить личные сообщения | Вход

   Страница 1 из 9
На страницу: 1, 2, 3, 4, 5, 6, 7, 8, 9  След. | Все страницы
Поиск в этой теме:
Железный канал: «Электронная бухгалтерия - 1с и тд.»
SASH
 790 EGP


Канцелярская крыса
Репутация: 67
Сообщения: 2557
Откуда: Санкт-Петербург
Зарегистрирован: 07.02.2002
Помогите пожалуста найти в сети 21 релиз 1С 7.7 лучше SQL но если не будет то обычный сетевой.
И желательно к нему крек.
Буду признателен.

Последний раз редактировалось: Мамонт (10:46 08-12-2015), всего редактировалось 3 раз(а)
    Добавлено: 13:05 20-11-2003   
freeze
 312 EGP


Ведмедь Сибирский
Репутация: 46
Сообщения: 1072
Откуда: Томск
Зарегистрирован: 22.08.2002
В сети вряд ли ты его найдешь... Опасается народ, значить..Гы-гы
Я попытаюсь поискать. Вроде знакомые есть. Если найду, вышлю на мыло. Кусками.
_________________
Когда мужчине плохо, он ищет жену. Когда мужчине хорошо, его ищет жена.
    Добавлено: 07:26 22-11-2003   
Volodya
 235 EGP


Рейтинг канала: 1(8)
Репутация: 42
Сообщения: 650
Откуда: Москва
Зарегистрирован: 23.09.2002
О! Мона я тута вопросик задам?

Как, блин, убрать с глаз долой помеченные на удаление записи?
_________________
Свободу нельзя дать - свободу можно только взять.
    Добавлено: 22:52 22-11-2003   
Harley
 1525 EGP


Рейтинг канала: 4(78)
Репутация: 336
Сообщения: 15406
Откуда: Москва
Зарегистрирован: 07.02.2001
В монопольном режиме удаляешь данный документы. Иначе никак.
_________________
Я привык говорить людям правду в глаза...
    Добавлено: 22:59 22-11-2003   
Volodya
 235 EGP


Рейтинг канала: 1(8)
Репутация: 42
Сообщения: 650
Откуда: Москва
Зарегистрирован: 23.09.2002
Цитата:
В монопольном режиме удаляешь данный документы. Иначе никак.

Млин... Мине жалко... А в справочниках тож?
_________________
Свободу нельзя дать - свободу можно только взять.
    Добавлено: 23:25 22-11-2003   
freeze
 312 EGP


Ведмедь Сибирский
Репутация: 46
Сообщения: 1072
Откуда: Томск
Зарегистрирован: 22.08.2002
Для справочника - делаешь кнопку, сопоставляешь ей примерно такую процедуру:


Процедура УстановитьФильтр()
Список.СоздатьОбъект("СписокЗначений");
Буфер = СоздатьОбъект("Справочник.Главн");
// отбираем только те элементы, которые могут отображаться в текущем списке
Буфер.ВыбратьЭлементы();
Пока Буфер.ПолучитьЭлемент() = 1 Цикл
// отбираем только те элементы, которые удовлетворяют заданному признаку
Если (Буфер.ПометкаУдаления() = 0) Тогда
Список.ДобавитьЗначение(Буфер.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
ИспользоватьСписокЭлементов(Список);
КонецПроцедуры


Для журнала документов - чуть посложнее. Похоже, придется создавать специальную графу журнала и по ней делать отбор. Короче, проктология...

ЗЫ кстати, если у народа есть надобность в доке по 1С в html-формате, то могу выложить где-нить.

ЗЗЫ В chm тоже есть. Если сильно надо - могу скинуть на мыло. Около 2Мб.
_________________
Когда мужчине плохо, он ищет жену. Когда мужчине хорошо, его ищет жена.
    Добавлено: 09:16 23-11-2003   
freeze
 312 EGP


Ведмедь Сибирский
Репутация: 46
Сообщения: 1072
Откуда: Томск
Зарегистрирован: 22.08.2002
2SASH - млин, пока ничего нет. есть 19 или 20-й, что-то вроде. Я типовыми конфигурациями не пользуюсь, так что все через знакомых. Может, в понедельник-вторинк что-нибудь скажут..
_________________
Когда мужчине плохо, он ищет жену. Когда мужчине хорошо, его ищет жена.
    Добавлено: 12:46 23-11-2003   
Star'ik
 325 EGP


Рейтинг канала: 3(48)
Репутация: 71
Сообщения: 1878
Откуда: Msk
Зарегистрирован: 29.04.2003
Есть возможность в конфигураторе поставить "непосредственное удаление объектов" в "Задача"->"Свойства"

После этого при нажатии Del элемент удаляется сразу (нужно поставить соотв. опцию в "Настройки")

Для удаления помеченных можно использовать следующую процедуру

Процедура УдалениеПомеченныхОбзектовСправочника(НазваниеСправочника)
Спр = СоздатьОбъект("Справочник."+НазваниеСправочника);
СЗ = СоздатьОбъект("СписокЗначений");
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Если Спр.ПометкаУдаления() = 1 Тогда
СЗ.ДобавитьЗначение(Спр.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
НачатьТранзакцию();
Для А=1 по СЗ.РазмерСписка() Цикл
Спр.Удалить()
КонецЦикла;
ЗафиксироватьТранзакцию();

КонецПроцедуры
_________________
Все хорошее когда-нибудь кончается
    Добавлено: 15:59 23-11-2003   
Volodya
 235 EGP


Рейтинг канала: 1(8)
Репутация: 42
Сообщения: 650
Откуда: Москва
Зарегистрирован: 23.09.2002
Фризз
У мя диал ап, а то б я аж запрыгал бы от радости Улыбка А нигде выложить низя? Я б ее в три-четыре приема скачал бы...

Старик
Удалить - не проблема. Проблема скрыть. Буду посмотреть предложенный Фризом вариант.
_________________
Свободу нельзя дать - свободу можно только взять.
    Добавлено: 00:27 24-11-2003   
freeze
 312 EGP


Ведмедь Сибирский
Репутация: 46
Сообщения: 1072
Откуда: Томск
Зарегистрирован: 22.08.2002
Выложить вроде бы некуда. Давай отправлю на мыло. Разобью куска на три.
_________________
Когда мужчине плохо, он ищет жену. Когда мужчине хорошо, его ищет жена.
    Добавлено: 05:25 24-11-2003   
Star'ik
 325 EGP


Рейтинг канала: 3(48)
Репутация: 71
Сообщения: 1878
Откуда: Msk
Зарегистрирован: 29.04.2003
Volodya :


-+=Скип=+-

Старик
Удалить - не проблема. Проблема скрыть. Буду посмотреть предложенный Фризом вариант.


Просто это долго работает...
_________________
Все хорошее когда-нибудь кончается
    Добавлено: 08:24 24-11-2003   
Volodya
 235 EGP


Рейтинг канала: 1(8)
Репутация: 42
Сообщения: 650
Откуда: Москва
Зарегистрирован: 23.09.2002
Угу... Поковырялся, потвыкал... Знацца, я так понял, новую строку при этом не добавить? Ни по инсерту, ни копированием? Не, так не пойдет... Я так мыслю, что окромя как добавить истчо одни атрибут и синхронизировать его с отметками и сделать обор по нему вариантов больше нет?
_________________
Свободу нельзя дать - свободу можно только взять.
    Добавлено: 23:09 24-11-2003   
Harley
 1525 EGP


Рейтинг канала: 4(78)
Репутация: 336
Сообщения: 15406
Откуда: Москва
Зарегистрирован: 07.02.2001
Крокыч, гад редкостный, слабо ответить, как программер 1С? Инет нафиг оключу.... Ой, не могу!..
_________________
Я привык говорить людям правду в глаза...
    Добавлено: 23:38 24-11-2003   
freeze
 312 EGP


Ведмедь Сибирский
Репутация: 46
Сообщения: 1072
Откуда: Томск
Зарегистрирован: 22.08.2002
Volodya :
Угу... Поковырялся, потвыкал... Знацца, я так понял, новую строку при этом не добавить? Ни по инсерту, ни копированием?

Именно так Расстроен

Цитата:
Я так мыслю, что окромя как добавить истчо одни атрибут и синхронизировать его с отметками и сделать обор по нему вариантов больше нет?


Видимо, да. Кстати, похоже, что с журналом документов - это единственный вариант.
_________________
Когда мужчине плохо, он ищет жену. Когда мужчине хорошо, его ищет жена.
    Добавлено: 04:01 25-11-2003   
SASH
 790 EGP


Канцелярская крыса
Репутация: 67
Сообщения: 2557
Откуда: Санкт-Петербург
Зарегистрирован: 07.02.2002
freeze :
Выложить вроде бы некуда. Давай отправлю на мыло. Разобью куска на три.

Заранее спасибо , что поискал для меня.
А скока все это весит.У меня оптоволокно стомегабитное - ты скажи я качну !
    Добавлено: 11:55 25-11-2003   
SASH
 790 EGP


Канцелярская крыса
Репутация: 67
Сообщения: 2557
Откуда: Санкт-Петербург
Зарегистрирован: 07.02.2002
2freeze :

Я тебе в приват мыло вышлю куда слать.
    Добавлено: 11:59 25-11-2003   
freeze
 312 EGP


Ведмедь Сибирский
Репутация: 46
Сообщения: 1072
Откуда: Томск
Зарегистрирован: 22.08.2002
2Volodya: Ну как, скачал доку?
_________________
Когда мужчине плохо, он ищет жену. Когда мужчине хорошо, его ищет жена.
    Добавлено: 12:29 25-11-2003   
krok
 910 EGP


Рейтинг канала: 1(3)
Репутация: 158
Сообщения: 4424
Откуда: банановая держава
Зарегистрирован: 25.04.2001
Volodya :
О! Мона я тута вопросик задам?

Как, блин, убрать с глаз долой помеченные на удаление записи?


Вопрос такой: удалить из системы или просто спрятать?

Если удалить из системы - то (обычно) заходишь монопольно и Операции/удаление помеченных объектов,
НО если на этот объект есть ссылка - он не удалится, пока все ссылки не пометишь на удаление. либо программно, но тогда, если не поставишь проверок - возможно будут пустые реквизиты, либо мусор...

если надо скрыть, то где? Если в отчете, то просто ставишь проверку на пометку на удаление.
Если в справочнике, то проще перенести в другую папку (можно программно), если в журнале, то ничего не сделать, разве что действительно отбором по реквизиту, но овчинка выделки не стоит.
_________________
"Наступающая старость крутит пальцем у виска"
    Добавлено: 18:56 25-11-2003   
SASH
 790 EGP


Канцелярская крыса
Репутация: 67
Сообщения: 2557
Откуда: Санкт-Петербург
Зарегистрирован: 07.02.2002
Все скачалось и крякнулось как надо !
freeze - спасибо тебе.Супер!
    Добавлено: 22:10 25-11-2003   
freeze
 312 EGP


Ведмедь Сибирский
Репутация: 46
Сообщения: 1072
Откуда: Томск
Зарегистрирован: 22.08.2002
krok :

если надо скрыть, то где? Если в отчете, то просто ставишь проверку на пометку на удаление.
Если в справочнике, то проще перенести в другую папку (можно программно)


Точно. Например, использовать предопределенную процедуру глобального модуля
ПриУдаленииЭлемента( , )
В ней прописать перенос удаляемых в папку Удаленные.
Самый цивилизованный выход.
Единственно, что в процедуру нужно вписать все справочники, в которых сие действие должно осуществляться Подмигиваю . Да и потом, при отмене удаления не забывать переносить вручную их обратно.
_________________
Когда мужчине плохо, он ищет жену. Когда мужчине хорошо, его ищет жена.
    Добавлено: 07:01 26-11-2003   
Железный канал: «Электронная бухгалтерия - 1с и тд.»
На страницу: 1, 2, 3, 4, 5, 6, 7, 8, 9  След. | Все страницы
  
Показать: 
Предыдущая тема | Следующая тема |
К списку каналов | Наверх страницы
Цитата не в тему: Дизайн теладийских кораблей - летающая супница (М2) и насадка для миксера (TL-TS). (резюмировал Deeplom)

  » Электронная бухгалтерия - 1с и тд. | страница 1
Каналы: Новости | Elite | Elite: Dangerous | Freelancer | Star Citizen | X-Tension/X-BTF | X2: The Threat | X3: Reunion | X3: Terran Conflict | X Rebirth | X4: Foundations | EVE Online | Orbiter | Kerbal Space Program | Evochron | VoidExpanse | Космические Миры | Онлайновые игры | Другие игры | Цифровая дистрибуция | play.elite-games.ru | ЗВ 2: Гражданская война | Творчество | Железо | Игра Мечты | Сайт
   Дизайн Elite Games V5 beta.18